Locatrix - Degraded email sending from PlanSafe & PlanStudio to Microsoft domains – Incident details

Degraded email sending from PlanSafe & PlanStudio to Microsoft domains

Resolved
Degraded performance
Started 10 days agoLasted about 2 hours

Affected

Products

Degraded performance from 5:53 AM to 8:17 AM

PlanSafe

Degraded performance from 5:53 AM to 8:17 AM

PlanStudio

Degraded performance from 5:53 AM to 8:17 AM

Backend

Degraded performance from 5:53 AM to 8:17 AM

Account Service

Degraded performance from 5:53 AM to 8:17 AM

Updates
  • Resolved
    UTC
    Resolved

    This incident has been resolved. This issue only affected delivery to Microsoft 365 corporate customers, while delivery to consumer addresses (such as hotmail.com) remained unaffected.

  • Identified
    UTC
    Identified

    We are currently investigating this incident.

    PlanSafe and PlanSafe are experiencing issues with email sending being blocked to certain Microsoft 365 based customer email addresses. We are engaging with Microsoft to resolve the issue while a re-routing mitigation is being put in place.