PlanSafe outage

Resolved
Partial outage
Started 7 months ago Lasted 3 minutes

Affected

Products
PlanSafe
Updates
  • Resolved
    Resolved

    PlanSafe was briefly offline for 5 minutes this evening due to Microsoft Azure backend maintenance. The system is now operational.

  • Investigating
    Investigating

    PlanSafe cannot be accessed at the moment. We are currently investigating the issue.