Locatrix - Email Deliverability Issues – Incident details

Email Deliverability Issues

Identified
Partial outage 20 %
Started about 11 hours ago

Affected

Products

Partial outage from 6:00 PM to 12:00 AM

PlanSafe

Partial outage from 6:00 PM to 12:00 AM

PlanStudio

Partial outage from 6:00 PM to 12:00 AM

Updates
  • Identified
    Identified

    We have identified the cause being a rate limit imposed on our mail server by Microsoft. We are currently investigating potential mitigative measures, along with working with Microsoft to resolve this issue. If you are experiencing this issue, please wait a while before trying again.

  • Investigating
    Investigating

    We are aware of issues with emails being delivered to personal Microsoft email addresses, impacting outlook, live, and hotmail emails.

    This is affecting:

    PlanSafe

    • Email reminders

    • Access codes

    • New user invites

    • Certificate emails

    PlanStudio

    • Partnership invitations